仮想化技術 <第4回> EVN – Ciscoコンフィグ設定

EVN – Cisco IOS XEコンフィグ設定

下図を前提にコンフィグレーション方法を解説していきます。

virtualization03

1. VRFインスタンスとVnet Tagの定義

(config)# vrf definition RED
(config-vrf)# vnet tag 10
(config-vrf)# address-family ipv4

(config)# vrf definition BLUE
(config-vrf)# vnet tag 20
(config-vrf)# address-family ipv4

2. 物理インターフェースとVRFインスタンスの紐づけ

(config)# interface GigabitEthernet0/1
(config-if)# vrf forwarding RED
(config-if)# ip address 10.1.1.254 255.255.255.0

(config)# interface GigabitEthernet0/2
(config-if)# vrf forwarding BLUE
(config-if)# ip address 10.2.2.254 255.255.255.0

3. EVNトランクインターフェースの設定

(config)# interface GigabitEthernet0/0
(config-if)# vnet trunk
(config-if)# ip address 10.0.0.1 255.255.255.0

EVNトランクインターフェースの設定により、自動的にvnet tag番号と紐づいたサブインターフェースが作成されます。そして、EVNトランクインターフェースに設定したIPアドレスは、自動作成されるサブインターフェースに引き継がれることになります。

VRF-LiteとEVNのコンフィグの比較

上図において、VRF-Liteを実装する場合は以下のコンフィグ設定が手動で必要となります。

interface GigabitEthernet0/0
ip address 10.0.0.1 255.255.255.0

interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip vrf forwarding RED
ip address 10.0.0.1 255.255.255.0

interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip vrf forwarding BLUE
ip address 10.0.0.1 255.255.255.0

一方、EVNを実装する場合の手動でのコンフィグ設定量は以下だけとなります。

interface GigabitEthernet0/0
vnet trunk
ip address 10.0.0.1 255.255.255.0

vrf definition RED
vnet tag 10

vrf definition BLUE
vnet tag 20

以上のコンフィグは最小限の設定量であり、例えば物理インターフェースにマルチキャストの設定やそれに付随する設定をしている場合、VRF-LiteとEVNとでは手動で設定するコンフィグ量は大きく変わってきます。

最後に、EVNの主な仕様と制約について箇条書きします。

・ EVNトランクは、802.1qトランクをサポートする全ての物理I/Fで使用できます。
・ EVNトランクを設定したインターフェースには、VRF-Lite を設定できません。
・ RIP、IS-IS、OSPFv3はサポートされていません。OSPFv2はサポートされています。
・ EVNトランクでは、BGPのインターフェースのコマンドは継承されません。
・ EVNトランクでは、ACL、NAT、NetFlow、WCCPはサポートされていません。

  • このエントリーをはてなブックマークに追加