MPLS-VPN 検証構成とコンフィグ設定 その3

今回は、MPLS検証構成図のPEルータ(PE2)の設定例とステータス確認方法を紹介します。

MPLS-VPN:PEルータのコンフィグ設定

下図において、1台のPEルータは3台の論理ルータであることが分かります。

◆ CustomerA用のVRFとルーティングの設定

ip vrf CUSTA
rd 1:100
route-target import 10:100
route-target export 10:100

interface GigabitEthernet0/1
ip vrf forwarding CUSTA
ip address 172.16.2.254 255.255.255.0

ip route vrf CUSTA 192.168.2.0 255.255.255.0 172.16.2.1

◆ CustomerB用のVRFとルーティングの設定

ip vrf CUSTB
rd 2:200
route-target import 20:200
route-target export 20:200

interface GigabitEthernet0/2
ip vrf forwarding CUSTB
ip address 172.16.4.254 255.255.255.0

ip route vrf CUSTB 192.168.4.0 255.255.255.0 172.16.4.1

◆ グローバルルーティング用のIGP、LDP、MP-BGPの設定

ip cef

interface loopback1
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point

interface GigabitEthernet0/3
ip address 10.1.2.1 255.255.255.0
mpls ip

router bgp 65000
no bgp default ipv4-unicast
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback1

address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both

address-family ipv4 vrf CUSTA
redistribute static

address-family ipv4 vrf CUSTB
redistribute static

router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 10.1.2.1 0.0.0.0 area 0

mpls ldp router-id Loopback1

MPLS-VPN:PEルータのステータス確認コマンド

MPLS-VPNでは、PEルータでのルーティング確認が重要となってきます。今回はPE1ルータのステータス確認コマンドを紹介します。

◆ PE1# show ip route vrf CUSTA
⇒ MP-BGPにより「192.168.2.0/24」のBGPルートを受信していることを確認。

◆ PE1# show ip route vrf CUSTB
⇒ MP-BGPにより「192.168.4.0/24」のBGPルートを受信していることを確認。

◆ PE1# show ip cef vrf CUSTA 192.168.2.0
⇒ ラベルが2つ付いていることを確認。

◆ PE1# show ip cef vrf CUSTB 192.168.4.0
⇒ ラベルが2つ付いていることを確認。

◆ PE1# show ip bgp vpnv4 all
⇒ MP-BGPで通知された「Next Hop」は、MP-BGPピアのアドレスであることを確認。

◆ PE1# show ip bgp vpnv4 all 192.168.2.0
⇒ Extended Communityに「RT:10:100」が付加されていることを確認。
⇒ リモートのラベル(out)が付加されていることを確認。

◆ PE1# show ip route
⇒ 常にMPLS-VPN網内のルーティング情報だけがテーブルに存在することを確認。

  • このエントリーをはてなブックマークに追加