MPLS-VPN 検証構成とコンフィグ設定 その2

MPLS-VPNの検証構成とCEルータの設定を前回に紹介しました。今回はPEルータとPルータの設定を紹介します。MPLS-VPNにおいてPEルータの設定をマスターすることは最も重要です。

MPLS-VPN Step2:PEルータのコンフィグ設定

MPLS-VPNにおけるPEルータの設定量は少し多くなります。設定順よりも、設定項目を分けるという観点でコンフィグを紹介したいと思います。

MPLS-VPN検証で使用する物理ルータは上図の7台ですが、MPLS-VPNを理解している人は、PEルータについては「 1台の物理ルータを3台の論理ルータとして認識 」しているはずです。※ 3台の「3」という数字ですが、接続するCEルータの数だけこの数は増えていきます。

当方はMPLS-VPNの論理図を作成する場合は、CEルータの数だけ「論理PEルータ」を描いています。カスタマー接続用、グローバル接続用として分離して設定も考えていきます。なお、PE1 は PE2 の「2.2.2.2」のloopbackアドレスとMP-BGPピアを確立することとします。

◆ CustomerA用のVRFとルーティングの設定

ip vrf CUSTA
rd 1:100
route-target import 10:100
route-target export 10:100

interface GigabitEthernet0/1
ip vrf forwarding CUSTA
ip address 172.16.1.254 255.255.255.0

ip route vrf CUSTA 192.168.1.0 255.255.255.0 172.16.1.1

◆ CustomerB用のVRFとルーティングの設定

ip vrf CUSTB
rd 2:200
route-target import 20:200
route-target export 20:200

interface GigabitEthernet0/2
ip vrf forwarding CUSTB
ip address 172.16.3.254 255.255.255.0

ip route vrf CUSTB 192.168.3.0 255.255.255.0 172.16.3.1

◆ グローバルルーティング用のIGP、LDP、MP-BGPの設定

ip cef

interface loopback1
ip address 1.1.1.1 255.255.255.0
ip ospf network point-to-point

interface GigabitEthernet0/3
ip address 10.1.1.1 255.255.255.0
mpls ip

router bgp 65000
no bgp default ipv4-unicast
neighbor 2.2.2.2 remote-as 65000
neighbor 2.2.2.2 update-source Loopback1

address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both

address-family ipv4 vrf CUSTA
redistribute static

address-family ipv4 vrf CUSTB
redistribute static

router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 10.1.1.1 0.0.0.0 area 0

mpls ldp router-id Loopback1

以上のコンフィグ設定が「PE1」の1台に設定するMPLS-VPN関連のコンフィグとなります。

MPLS-VPN Step3:Pルータのコンフィグ設定

Pルータでは、ラベルスイッチングが行われるように適切に「IGPとLDP」の設定をすれば良いだけなのでシンプルです。ラベルスイッチングが行いたいインターフェース上で「 mpls ip 」を設定するのと「 mpls ldp router-id 」でインターフェースを指定するだけです。

Pルータの設定例は以下の通りです。PE1ルータと接続しているI/Fは「Gi0/1」として、もう一方のPE2ルータと接続しているI/Fは「Gi0/2」とします。

ip cef

interface loopback1
ip address 9.9.9.9 255.255.255.0
ip ospf network point-to-point

interface GigabitEthernet0/1
ip address 10.1.1.254 255.255.255.0
mpls ip

interface GigabitEthernet0/2
ip address 10.1.2.254 255.255.255.0
mpls ip

router ospf 1
network 9.9.9.9 0.0.0.0 area 0
network 10.1.1.254 0.0.0.0 area 0
network 10.1.2.254 0.0.0.0 area 0

mpls ldp router-id Loopback1

次回は残りの「PEルータ」のコンフィグ設定とステータス確認方法を紹介していきます。

  • このエントリーをはてなブックマークに追加