MPLS-VPN 検証構成とコンフィグ設定 その1

MPLS-VPNを理解する上で役立つ「 最小検証構成と最低限のコンフィグ 」を紹介します。

一昔前ならMPLS-VPNの実装は「キャリア」や「キャリアの担当部署」などの限られたSP系のネットワークエンジニアにとって必須のNW技術でありましたが、ゲーム会社等のインフラやサービス提供のための共通基盤インフラなどを構築する上でも、MPLS-VPNのスキルが必要とされてきており、EP系のネットワークエンジニアにとっても役立つ技術になっています。

数回に渡り紹介していきますが、MPLSの基礎知識がある人を前提としているので、ここでは詳細な技術解説はしませんし、構成図もI/FやIPアドレスの記載がなかったり少し不親切な記事となり分かりにくいかもしれませんが、検証環境構築の上でヒントになれば幸いです。

当方のプロジェクトチームに参加する人で「CCIE取得のために勉強しています!」という人にいつも当方が「こういう構成で学習してみてはどうですか」と伝えている内容です。本記事は技術解説というよりメモ程度の記事としてご参考頂ければ幸いです。

※ 先日 RT(Route Target)のスペルミスの細かいご指摘をありがとうございました。もしCCIEを目指していらっしゃるなら本記事は役立つかもしれません。その他にも色々な方々からご丁寧なご指摘メールを頂いたこと感謝します。この場を借りて御礼申し上げます。

MPLS-VPN検証構成図

MPLSの技術解説でも紹介している構成図ですが、図の通り、物理的には7台を用意します。

役割として「Pルータ」「PEルータ」「CEルータ」を用意することでMPLS-VPNを理解できるという観点からすれば、下図のB社のCEルータ2台を無しにした、5台が本当の意味で最小構成かもしれませんが、MPLS-VPNの動作をラベルやルーティングテーブルで実感するためには、やはりこの7台で検証することをお勧めします。※ 使用するLANケーブルは計6本です。

なお、検証環境を構築する上ではA社のCEルータ、PEルータ、Pルータの計5台で構築した上でA社間(192.168.1.0/24と192.168.2.0/24)で疎通を確認できてから、次にB社のCEルータを設定していくという形を取ることで構築上(設定上)の切り分けがしやすいと思います。

また、MPLS-VPNを実感するためにはA社もB社も同じプライベートIPアドレスを使用した方が良いかもしれませんが、初めてMPLS-VPNを動作検証する人はステータス確認の分かりやすさという観点から、上図の通りあえてA社とB社とで異なるアドレスを使用することがお勧め。

MPLS-VPN Step1:CEルータのコンフィグ設定

CEルータにはMPLSやVRFの設定は必要ありません。

企業ネットワークのWAN回線に「IP-VPN網」を利用したNWエンジニアなら認識があるかと思いますが、企業側(カスタマー側)のネットワーク機器の設定には、MPLSやVRFの設定は行いませんよね。ブランチ側のCEルータである場合には、ルーティング設定としてデフォルトルートを設定するだけであったり、センター側(本社やDC)のCEルータである場合には BGPの設定があるだけで、CEルータにはMPLSやVRFの設定は必要ありません。

次の設定例では、CEルータとPEルータ間のIPアドレスに「 172.16.X.0/24 」を使用します。End-to-Endの通信には、loopbackアドレスを使用します。

◆ CE1

interface loopback1
ip address 192.168.1.1 255.255.255.0

interface GigabitEthernet0/0
ip address 172.16.1.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 172.16.1.254

◆ CE2

interface loopback1
ip address 192.168.2.1 255.255.255.0

interface GigabitEthernet0/0
ip address 172.16.2.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 172.16.2.254

◆ CE3

interface loopback1
ip address 192.168.3.1 255.255.255.0

interface GigabitEthernet0/0
ip address 172.16.3.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 172.16.3.254

◆ CE4

interface loopback1
ip address 192.168.4.1 255.255.255.0

interface GigabitEthernet0/0
ip address 172.16.4.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 172.16.4.254

次回以降で「PEルータ」と「Pルータ」のコンフィグを紹介します。上記で紹介したように、CEルータの設定は簡単です。また、バックボーンとなるPルータの設定もシンプルです。最も難しいのはPEルータです。ここでの制御をマスターすることがMPLS-VPNにおいて重要です。

  • このエントリーをはてなブックマークに追加